Project Host Disconnected

Major incident Host Services
2020-06-20 19:36 WIB · 11 hours, 42 minutes

Updates

Resolved

The host service system is turned back

November 4, 2021 · 22:24 WIB
Issue

We will try figure it out our host project that have an internal error.

November 4, 2021 · 22:24 WIB

← Back